Email Sent as Attachment or File not Opening in Outlook

Issue

When I open a icalendar/ics file – it just opens the online outlook and does not add the meeting into my calendar or I have to take additional steps to add the calendar invite to my calendar. 

Cause

Default Application for .eml .ics and .msg is not set to Outlook in Windows. 

Resolution

You may need to set your default application to Outlook (classic) to resolve this. To do so:

  1. Click the  Windows start button 
  2. Type Default Apps
  3. Select Default Apps
  4. Select Outlook (classic) from the list
  5. Select .eml
  6. ​​​​​​Select Outlook (classic)
  7. Click Set default
  8. Repeat steps 6 and 7 for .ics and .msg files
  9. Open the email and try viewing the attachment again